Sally

A Tool for Embedding Strings in Vector Spaces

Dependencies

Debian and Ubuntu Linux

The following packages need to be installed for compiling Sally on Debian and Ubuntu Linux.

   gcc 
   libz-dev
   libconfig8-dev
   libarchive-dev 

For bootstrapping Sally from the GIT repository or manipulating the automake/autoconf configuration, the following additional packages are necessary.

   automake 
   autoconf 
   libtool

Mac OS X (Homebrew or MacPorts)

For compiling Sally on Mac OS X a working installation of Xcode is required including gcc. Additionally, the following packages need to be installed.

Homebrew packages

   libconfig   
   libarchive (from homebrew-dupes) 

MacPort packages

   libconfig-hr
   libarchive

Source code

For other operating systems the libraries are available as source code and need to be compiled for installation.

  zlib        http://www.zlib.net/
  libconfig   http://www.hyperrealm.com/libconfig/
  libarchive  http://libarchive.github.com/